Question for the DS owners

What DS version do I need to run the M01?

I’ve just got an urge to get back into the DS again!

Leave a Reply

%d bloggers like this: